Administrator’s Plus
Enhanced Security

[Diagram of software interface]

Printed October 2005
**Introduction**

**What is Enhanced Security?**

The Enhanced Security feature is an upgrade to the previous method of adding users and granting rights to Administrator’s Plus. Once you have activated Enhanced Security, you are able to:

- Assign rights by user and by school
- Assign separate levels of rights to the current school year and past years
- Allow users from other RS4 folders to access your data with access rights you control
- Designate Assistant Supervisors
- Make schools invisible to specific users
- Use an improved interface that includes shortcut options to simplify the management of large user lists

**What are Home Users and Remote Users?**

The Enhanced Security feature introduces some new concepts in regard to managing access to your school’s data. You can now manage rights for Home Users and Remote Users. This document will also refer to Home Schools and Remote Schools. What do these terms mean?

<table>
<thead>
<tr>
<th>Home School</th>
<th>A school located in a single RS4 folder to which you are the Supervisor.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home User</td>
<td>A user whose account you have created in your Home RS4 folder.</td>
</tr>
<tr>
<td>Remote School</td>
<td>A school located in a folder to which you are not the Supervisor.</td>
</tr>
<tr>
<td>Remote User</td>
<td>A user whose account was created in a Remote RS4 folder.</td>
</tr>
</tbody>
</table>

Here is an example to better define these terms:

You are the Supervisor for two schools, The Orr’s Island School and the Orr’s Island Early Childhood Center. These schools share one RS4 folder on drive K:\. They are your *Home Schools*. Inside K:\RS4\User are the folders of your *Home Users*.

Across town is the Orr’s Island Middle/High School, for which you are not the Supervisor. You have access to this school’s RS4 folder on the S:\ drive of your Wide Area Network. The user accounts found in S:\RS4\User can be given access to your school as *Remote Users*. Similarly, your users can be granted permission to access the Middle/High school, and you would then refer to this school as a *Remote School*.

The screenshots and examples given in this document are all based upon the above example.
**Activating Enhanced Security**

In order to use the Enhanced Security feature, you must first activate it.

β Click Help ⇒ **Logged in Users** to verify that no users are currently logged in.  
γ Perform a backup of your entire RS4 folder.

**NOTE:** You must be logged into Administrator’s Plus as Supervisor to perform the tasks outlined in this document

δ Go to File ⇒ **Add/Remove Users**

ε On the Add/Remove Users screen, put a check in **Activate Enhanced Security**.

The Enhanced Security Wizard prompts you to confirm the path to your Home RS4 folder. When the wizard is complete, you will be prompted to log into Administrator’s Plus again. You can now access the Enhanced Security feature.
Managing Users

The manage users screen is used to add or remove users as well as to assign those users rights to each Administrator’s Plus module in your Home School(s). You can also view your Home Users’ rights to Remote Schools from here.

β Go to File ➔ Users/Security (Enhanced)

χ Choose Manage Users

The Manage Home Users menu opens. This is the main screen for adding and editing users and passwords for your Home School.
MANAGE HOME USERS

**HOME RIS4 LOCATION:** "K:\RIS4"

<table>
<thead>
<tr>
<th></th>
<th>NAME</th>
<th>PASSWORD</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>SUPERVISOR</td>
<td>***********</td>
</tr>
<tr>
<td>2</td>
<td>GUIDANCE</td>
<td>***********</td>
</tr>
<tr>
<td>3</td>
<td>OFFICE</td>
<td>***********</td>
</tr>
<tr>
<td>4</td>
<td>MISSLATHI</td>
<td>***********</td>
</tr>
<tr>
<td>5</td>
<td>6</td>
<td>7</td>
</tr>
</tbody>
</table>

**Help:**
- ADD Users to this list and then edit their rights.
- Double click a password entry to view the password.
Creating a New User and Assigning Rights

Before users can access Administrator’s Plus, they must first be added to the user list. Before new users can log in, you will need to activate their account and assign rights to modules and schools before they will be able to log in to Administrator’s Plus. To add a new user and assign them rights:

β Click F2: New User to add a user in the first available empty slot. Type the new user’s name and press the Enter key to save your changes.

NOTE: User names may contain up to 20 characters, and passwords may contain up to 16 characters. User names and passwords may contain any combination of alpha or numeric characters. User names and passwords are not case sensitive, and may not contain symbols such as @, $, #, etc.

χ The cursor is now in the password field. Enter a password for the user and press Enter. The following message appears:

δ Click Yes to assign the user’s rights. The Edit Home User Rights screen appears:

NOTE: If you click No, you can assign rights at a later time by selecting the user name in the list and clicking F4: Edit Rights.

In this example, the user “Joan” is assigned rights to the Orr’s Island School.
β To begin, click on the first school you wish to give Joan rights to. If you only have one school in your RS4 folder, this school is automatically highlighted.

χ Click on the Edit Rights for Joan button. A new window opens that allows you to see Joan’s rights to each module and database page. You can also see if the user account is active, and whether or not that user has been granted Assistant Supervisor rights (see page 9).

δ In order for Joan to log in, her account must first be activated. Do this by putting a check in the Active box in the top-right of the screen.

ε Assign rights to each module and Address page by clicking in the appropriate column. The levels of rights are defined as:

- **All Rights**: The user has rights to view, edit, and delete all information in this module/Address page.
- **Read Only**: The user may view all of the data in this module/Address page, but they may not edit or delete the data.
- **No Rights**: The user may not access the data in this module/Address page.

**NOTE**: When assigning rights to the Data Base module, you must assign rights to each page of the database as well as the module itself. Page rights cannot supersede the rights assigned to the Data Base module.

φ When you have finished assigning the user’s rights, click F10: Done.
You can now see Joan’s rights to the Orr’s Island School, color coded to visually represent her rights to each module. Modules with All rights are colored green, Read Only rights are colored yellow, and No rights are colored red. You can also see on the far right that her account is active, but she has not been granted Assistant Supervisor status.

Click Finish to save your changes and exit the Edit Home User Rights screen.

NOTE: In addition to granting your users rights in the current and scheduling year, you can assign rights for the previous years in your RS4 folder. Click the Past Years tab at top right of the Edit Home User Rights screen to assign rights for past years. Denying rights to past years prevents users from accessing modules in past years folders, but it does not prevent them from changing archival information in the current year.

**Shortcut Buttons**

There are several buttons on the Edit Home User Rights screen that can save you time when assigning rights to your users. The functions of these buttons are detailed below.

**Copy Rights From Another User:** This button allows you to copy all of the rights from one user to the user you are currently editing.

**Copy Rights From Another School:** If you have already assigned rights for the current user to one school in your RS4 folder, you can apply them to any other school in your RS4 folder using this button.

**Shortcuts:** Clicking this button gives you the following options for quickly assigning the current user’s rights:

- Set All Module Rights for the Highlighted School to “A”
- Set All Module Rights for the Highlighted School to “R”
- Set All Module Rights for the Highlighted School to “N”
- Set All Module Rights for All Schools to “A”
- Set All Module Rights for All Schools to “R”
- Set All Module Rights for All Schools to “N”
**Assistant Supervisor Rights**

In addition to allowing users access to program modules and Address screen pages, you can also grant users Assistant Supervisor rights. Assistant Supervisors have access to many areas of the program that were previously reserved only for the Supervisor. The table below indicates which programs and utilities Assistant Supervisors can access that other users cannot:

<table>
<thead>
<tr>
<th>Module</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB</td>
<td>Customize DB-&gt; Setup family feature-&gt; Setup family fields</td>
</tr>
<tr>
<td>DB</td>
<td>Customize DB-&gt; Setup family feature-&gt; Setup initial family accounts</td>
</tr>
<tr>
<td>DB</td>
<td>Customize DB-&gt; Setup family feature-&gt; Synchronize families</td>
</tr>
<tr>
<td>DB</td>
<td>Address-&gt; Setting the following field properties: field validation, field type and change case</td>
</tr>
<tr>
<td>DB</td>
<td>Address-&gt; Other options-&gt; Import fields from ASCII file</td>
</tr>
<tr>
<td>DB</td>
<td>Address-&gt; Other options-&gt; Move field data</td>
</tr>
<tr>
<td>AT</td>
<td>HR Forms-&gt; Homeroom attendance form specifications-&gt; Homeroom field for GQ rosters</td>
</tr>
<tr>
<td>RC</td>
<td>Customize RC-&gt; Edit report card comments</td>
</tr>
<tr>
<td>RC</td>
<td>Customize RC-&gt; Edit number grade print table</td>
</tr>
<tr>
<td>RC</td>
<td>Customize RC-&gt; Enter department names</td>
</tr>
<tr>
<td>RC</td>
<td>Customize RC-&gt; Enter skills and concepts</td>
</tr>
<tr>
<td>SC</td>
<td>Customize SC-&gt; Enter scheduling rotation #1</td>
</tr>
<tr>
<td>SC</td>
<td>Customize SC-&gt; Enter/scheduling rotation #2</td>
</tr>
<tr>
<td>SC</td>
<td>Customize SC-&gt; Enter/Receive meeting times for rotation #2</td>
</tr>
<tr>
<td>SC</td>
<td>Customize SC-&gt; Enter/Receive meeting times for rotation #2</td>
</tr>
<tr>
<td>SC</td>
<td>Customize SC-&gt; Enter/Receive day of week headings for rotation #2</td>
</tr>
<tr>
<td>SC</td>
<td>Customize SC-&gt; Enter department names</td>
</tr>
<tr>
<td>SC</td>
<td>Customize SC-&gt; Enter course requests spec. Changing the 'Ability to add sections' option,</td>
</tr>
<tr>
<td>BI</td>
<td>Invoices-&gt; Spec-&gt; Change last invoice No</td>
</tr>
<tr>
<td>BI</td>
<td>Invoices-&gt; Edit invoice</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; Abbreviated Names</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; Report Card Names</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; Archival Names</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; Discipline Names</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; Billing Names</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; Skills Names</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; SuperDB tables</td>
</tr>
<tr>
<td>GNL</td>
<td>File-&gt; maintenance-&gt; Rebuild-&gt; Extended RC file</td>
</tr>
<tr>
<td>GNL</td>
<td>Print-&gt; Reports conversion/restore utility</td>
</tr>
<tr>
<td>GNL</td>
<td>E-Mail-&gt; Initial setup wizard</td>
</tr>
<tr>
<td>GNL</td>
<td>Tools-&gt; GQ-&gt; Send Attendance to Grade Quick: Specifications-&gt; Settings Home room field</td>
</tr>
</tbody>
</table>
Managing Schools

The Manage Schools menu is used to maintain the list of Home Schools available to your users. This menu is used to add new schools as well as to inactivate or remove schools that are no longer stored in your Home RS4 folder.

β To access the Manage Users menu, go to File ⇐ Users/Security (Enhanced)

χ From the Enhanced Security menu, Choose Manage Users

The Manage Home Schools screen opens. This is where you maintain the list of Home Schools.
**Adding a New School**

To add a new Home School, click the F5: Refresh button. Your Home RS4 folder will be scanned for any schools not already in the list. A message box appears for any new schools found.

![Image](image.png)

After you click Done, the new school appears in your Home School list.

**Editing User Rights by School**

Use the Manage Home Schools screen to add or edit user rights without returning to the Manage Users screen. Highlight the school for which you wish to manage rights and click the F4 Edit button. The Edit Home School Rights screen appears.

![Image](image.png)

You can now see each of your user’s rights to this school. Assign user rights in the Edit Home School Rights screen in the same manner as in the Edit Home User screen. Please see page 6 for more information on how to assign user rights.
Inactivating Schools

The Manage Home Schools screen can also be used to inactivate schools your users no longer need access to. To inactivate a school, click the Yes button next to the school you wish to inactivate. There will now be a No in the Active column for that school. Click the Next button to save your changes and close the Manage Home Schools screen.

Your users will no longer have access to the inactive school, regardless of whether they have a check in the Active box for that school on the Edit Home User Rights screen. Changing the school’s status from Inactive to Active restores the users’ access to that school with the same rights they were assigned previously.
Remote Access

The process of giving your Remote Users access to Remote Schools involves three steps. First, the Home School grants access to Remote Users. The Home School also assigns rights as to what modules and schools the Remote Users may access. Finally, the Remote Supervisor makes your school visible to his users.

NOTE: If you currently use multiple desktop icons to access schools on different drives, use the following process to set up remote access to those schools. After you have finished, delete your extra icons and manage all of your schools from a single icon.

Granting Access to Remote Users

Before Remote Users can access a Remote School, you must first grant permission to be accessed remotely. To grant Remote access to your school:

β Go to File → Users/Security (Enhanced)

χ Choose Manage Remote Access

δ Choose Grant Access to Remote Users.
The Add Remote Users screen appears. Click the F2: New Remote Users button. Browse to the location of the RS4 folder containing the Remote Users to whom you wish to grant access. This can be a mapped drive or UNC path. Once you have indicated the appropriate path, a screen opens showing you the users available on that drive.

Deselect any users you do not wish to include and click Done. The Manage Remote Users screen is populated with the Remote Users you have enabled.
**Assigning Rights to Remote Users**

To assign rights to Remote Users, highlight a user and click the F4: Edit Rights button. The Edit Remote User Rights screen appears.

You can now see each of the Remote User’s rights to your school(s). Assign user rights in the Edit Remote User Rights screen in the same manner as in the Edit Home User Rights screen. Please see page 6 for more information on how to assign user rights.

**Remote School Visibility**

Now that the Remote School has added your Home Users and granted them rights to the necessary Administrator’s Plus program modules, you must make the Remote Schools visible to your users.

β Choose **Enable Your Users to Access Remote Schools.**
The Manage Remote Schools screen appears.

χ Click F2: New Remote School to add Remote Schools that have granted access to your Home Users. Select the path to the Remote School. This can be a mapped drive or UNC path. Once you indicate the appropriate location, a screen will open showing you the schools available on that drive.

δ Deselect any schools you do not wish to add to your Remote school list, then click Done.
**Viewing Home User Rights to Remote Schools**

Remote Schools differ from Home Schools in that you, as the Supervisor, will not grant any rights to the Remote Schools. These rights have been granted at the Remote School, and automatically apply to the user after you have added the Remote School on the Manage Remote Schools list. The rights to the Remote School can only be changed by the Supervisor of the Remote School. To view the rights your Home Users have been given at Remote Schools:

1. Go to **File ➔ Users/Security (Enhanced)**
2. Choose **Manage Users**
3. Highlight the user whose Remote rights you wish to view and click F4: Edit Rights.
4. Click the Remote Rights button in the bottom-right of the Edit Home User Rights screen. You can now see the rights that user has to each school in your Remote School list.

---

**Accessing Remote Schools**

Once you have completed the process of adding the Remote School list, the users that have been granted rights to the Remote School will be able to select it from the school drop down at the top of the screen. Remote Schools appear on the list in brackets to distinguish them from the Home Schools on the list.